Neil Hopcroft

A digital misfit

Archive for June 2016

Adding project of-octcdf

The octcdf package doesn’t have any dependencies, it is described as being obsolete, now replaced by netcdf, however it appears to have recent development. It contains a src/ directory with a configure script.

Adding project of-ocs

The ocs package depends upon the odepkg package. It contains a src/ directory with a makefile.

Adding project of-ncarray

The ncarray package depends upon the netcdf and statistics packages. It contains no src/ directory and can be installed directly.

Octave build break #916

The octave build has broken with an error in TEXI2DVI: TEXI2DVI doc/interpreter/octave.dvi /usr/local/bin/texi2dvi: etex exited with bad status, quitting. make[2]: *** [doc/interpreter/octave.dvi] Error 1 This is most likely a result of Changeset 21126:16bb4651a54d by Mike Miller : maint: Include profiler HTML templates in the distribution (bug #48116) * scripts/profiler/module.mk (scripts_EXTRA_DIST): Include$(scripts_profiler_html_DATA) in the list. …which […]

Adding project of-bim

The bim package depends upon the fpl and msh packages. It doesn’t have a src/ directory and can simply be installed.

Adding project of-msh

The msh package depends upon of-splines. This project builds, but has a dependency upon dolfin which isn’t currently met, I will investigate that at some point in the future.

Adding project of-fpl

The fpl package doesn’t have any dependencies or src/ directory, it can just be installed directly.

Adding project of-database

The database package depends upon the struct package and has a src/ directory containing a bootstrap script. Running this script leads to and error: checking for PQconnectdb in -lpq… no configure: error: unable to find the PQconnectdb() function in pq This seems to be because it cannot find libpq.so – checking on the system libpq.so.5 […]